Jump to content


Issue with monitor

  • Please log in to reply
2 replies to this topic

#1 Jon Beattie

Jon Beattie

    Advanced Member

  • Sustaining Members
  • 206 posts
  • Long Island

Posted 10 November 2008 - 02:54 PM

I have one of the tiffen 7" 700 nit monitors they have made for them by marshall. The other day I was on set. Built my rig and when I fired up the monitor a blue screen came on with " no signal". Not even the framelines would work.

I throw my backup monitor up and it worked fine, so i know its not the sled as I also connected the tiffen monitor in 3 different places.

I have emails out to tiffen, cramped attic and Terry West. Is there anyone else that may be able to help? I've seen mention of this before, but no solution.

EDIT: its not the marshall custom. To clearify its the large housing SD monitor that came with the clipper2 and the flyers.
  • 0

#2 Robert Starling SOC

Robert Starling SOC

    Advanced Member

  • Sustaining Members
  • 1133 posts
  • Las Vegas, NV

Posted 11 November 2008 - 12:20 AM

Jon, just pick up the phone and call Tiffen or Peter Abraham or Frank Rush or Michael Craigs at Ext 17 at the factory. The factory is overwhelmed with business right now and the phone is the best way. While they may be overwhelmed at the moment once they know you have an issue they'll take care of it or at least they always have for me so far. There is also a 24/7 EMERGENCY customer service number. Search for postings by Frank Rush and I think you'll find a recent post with his cell listed and a few other numbers.

My 7" Clipper 24 LCD was plagued with problems for a short time and the factory was very very responsive including offering to courier it back to me on-set at Universal. It was under warranty and they ultimately replaced it with a few modifications. Mine was not a blue screen issue, more of a heat related problem. Whatever they did it's prefect now.

All the best!
  • 0

#3 Jon Beattie

Jon Beattie

    Advanced Member

  • Sustaining Members
  • 206 posts
  • Long Island

Posted 11 November 2008 - 09:02 AM

Peter called me back yesterday. Going to trouble shoot with him. Get a loaner and send mine out to the factory.
  • 0

Ritter Battery

GPI Pro Systems

Omnishot Systems

rebotnix Technologies

Betz Tools for Stabilizers

PLC Electronics Solutions

Camera Motion Research

Varizoom Follow Focus


Paralinx LLC

Wireless Video Systems


PLC - Bartech

Boland Communications