Jump to content



Photo

Canisters jiggling in Titan arm

Pro canister arm titan

  • Please log in to reply
8 replies to this topic

#1 Damien Tessandier

Damien Tessandier

    New Member

  • Sustaining Members
  • 9 posts
  • Paris, France, Europe

Posted 16 December 2016 - 04:40 PM

Hi all, 

 

I bought a brand new Titan Arm last summer.

After 10 weeks shooting in Morocco, it needed to be cleaned up.

When I built it back after cleaning, and screwed each canister in his bone, I've seen some trouble with 2 of them.

 

On both higher and lower section of the arm, the upper canisters are jiggling. 

Before that, they always had been stucked in place, no jiggling. 

Of course I've tried different canister in different arm section. It's always the upper canister that is moving. 

 

I can't find a way to fix this.

 

Any idea's welcome!

 

 

Thanks!

 

 

 


  • 0

#2 Iain Baird

Iain Baird

    Advanced Member

  • Sustaining Members
  • 267 posts
  • Toronto

Posted 16 December 2016 - 04:55 PM

Are they jiggling while under load?


  • 0

#3 Damien Tessandier

Damien Tessandier

    New Member

  • Sustaining Members
  • 9 posts
  • Paris, France, Europe

Posted 16 December 2016 - 05:21 PM

Not while under load. But before this first cleaning they were not jiggling at all, even off load.


  • 0

#4 Jens Piotrowski SOC

Jens Piotrowski SOC

    Advanced Member

  • Sustaining Members
  • 1654 posts
  • Los Angeles, CA

Posted 16 December 2016 - 05:26 PM

That's fully normal, they need to be under load not to jiggle.
  • 1

#5 Damien Tessandier

Damien Tessandier

    New Member

  • Sustaining Members
  • 9 posts
  • Paris, France, Europe

Posted 16 December 2016 - 06:10 PM

then I wonder why are they not jiggling when coming out of factory?


  • 1

#6 Jens Piotrowski SOC

Jens Piotrowski SOC

    Advanced Member

  • Sustaining Members
  • 1654 posts
  • Los Angeles, CA

Posted 16 December 2016 - 06:59 PM

They are, mine were, all eight canisters. Call Jack to confirm.
  • 2

#7 Jens Piotrowski SOC

Jens Piotrowski SOC

    Advanced Member

  • Sustaining Members
  • 1654 posts
  • Los Angeles, CA

Posted 16 December 2016 - 07:04 PM


  • 0

#8 Shawn Wang

Shawn Wang

    Advanced Member

  • Sustaining Members
  • 91 posts
  • Vancouver, Canada

Posted 16 December 2016 - 07:35 PM

so was mine. jiggling not under load... ..

 

tho my arm has a sharp click sound sometimes on subtle movements.... still trying to figure out where it came from...


  • 0

#9 Damien Tessandier

Damien Tessandier

    New Member

  • Sustaining Members
  • 9 posts
  • Paris, France, Europe

Posted 17 December 2016 - 08:08 AM

ok, thank you all for your help! I've already sent an email to jack. Maybe it was just unusual that my arm was not jiggling when coming out of factory. 

I appreciate a lot the help from this community.

 

You rock guys! Thanks


  • 0





Also tagged with one or more of these keywords: Pro, canister, arm, titan

GPI Pro Systems

Omnishot Systems

Betz Tools for Stabilizers

Teradek

PLC Electronics Solutions

Varizoom Follow Focus

Wireless Video Systems

rebotnix Technologies

Paralinx LLC

BOXX

Media Blackout - Custom Cables and AKS

PLC - Bartech

IDX

Ritter Battery

Boland Communications