Jump to content


Gimbal Handle bearings/screw locking up

MK-V Evolution gimbal (old)

  • Please log in to reply
1 reply to this topic

#1 Rupert Nel

Rupert Nel

    Advanced Member

  • Sustaining Members
  • 31 posts
  • Cape Town, South Africa

Posted 11 April 2016 - 12:23 PM

Hi guys


I have a old MK-V Evolution gimbal, that is not happy at the momemt. I basically took the gimbal apart to clean the bearings, I have not put any oil on the bearings after cleaning it, I don;t have the correct oil and I read on the forum some guys run their gimbals dry.

The pan bearings is not feeling so smooth as they used to be with a little "skiff" sound when panning, so that would be the first thing. The second and main problem is the handle and bearings/screw inside the handle that effects the tilt.

Everytime I put the rig on the gimbal the handle/tilt locks completely into one place so I cant tilt the rig unless I completely force it. I then have to tweak the screw that goes into the handle through to the gimbal while still loaded with the rig to get it out of the lock, then the tilt works again but soon after just locks back up.

So there must be an issue with how the screw and the bearings are sitting in the handle.


Anyone know what I can check to try and fix this? And is it better to rather get suitable oil for the bearings?


Thanks so much.



  • 0

#2 Jens Piotrowski SOC

Jens Piotrowski SOC

    Advanced Member

  • Sustaining Members
  • 1624 posts
  • Los Angeles, CA

Posted 11 April 2016 - 06:18 PM

sounds like it's needs TLC, contact MK-V directly



  • 0

rebotnix Technologies

Betz Tools for Stabilizers

Camera Motion Research

Varizoom Follow Focus

PLC - Bartech

Wireless Video Systems

Boland Communications

GPI Pro Systems



Paralinx LLC

PLC Electronics Solutions

Ritter Battery

Omnishot Systems