Jump to content


Problem with my gen2 PRO monitor

  • Please log in to reply
1 reply to this topic

#1 youareinmyshot


    New Member

  • Members
  • Pip
  • 1 posts

Posted 21 March 2013 - 08:18 AM

Hey all. Need a little help. I have a gen 2 pro monitor and all of a sudden the image will go fuzzy and then will come back sharp randomly and again will go fuzzy. It's not a battery issue... I remember on the old cp3a it used to mean that a focus tube was going. As far as I know, can't see any focus adjustment inside the gen 2 monitor. I know my gen 1 monitor has a focus adjustment, but have looked everywhere for one in the gen 2. Any ideas on what the problem is? Thanks in advance.

  • 0

#2 Erwin Landau

Erwin Landau

    Advanced Member

  • Moderators
  • PipPipPip
  • 1699 posts
  • TBD

Posted 21 March 2013 - 11:34 AM

Hi Steven,


Could be an issue with the High Voltage Power Supply. I had one of my TB-6's send to Greg Bubb a couple of weeks ago. It started with a fuzzy picture and then it would lose picture intermittent and finally the screen stayed dark, but the Power indicator LED was still on. Had to send it in.


As far as I know GPI is no longer manufacturing Green screens but does still accept the Monitors for service, actually they send it off to Warren and he takes care of the repair. Give them a call.  



Also, could you please use your real name or use your old account (S. Adelson) I send you a message.


Good Luck with your monitor.





  • 0

Boland Communications

GPI Pro Systems

Varizoom Follow Focus

Omnishot Systems

PLC - Bartech


Camera Motion Research

Ritter Battery



rebotnix Technologies

PLC Electronics Solutions

Paralinx LLC

Betz Tools for Stabilizers

Wireless Video Systems