Jump to content



Photo

Lubricating Arm Post


  • Please log in to reply
2 replies to this topic

#1 Alex Kolb

Alex Kolb

    Advanced Member

  • Members
  • PipPipPip
  • 82 posts
  • Midwest USA

Posted 31 October 2012 - 08:48 PM

Hi all,

My arm post is squeaking and not smooth in it's rotation anymore. I've removed it easily, but I'm not sure what substance to apply.
Any feedback is appreciated. Next show is Friday, and I'd love to have it smooth again by then.

Cheers,
Al
  • 0

#2 Eric Fletcher S.O.C.

Eric Fletcher S.O.C.

    Advanced Member

  • Sustaining Members
  • 2922 posts
  • LA, Ca

Posted 31 October 2012 - 09:11 PM

Hi all,

My arm post is squeaking and not smooth in it's rotation anymore. I've removed it easily, but I'm not sure what substance to apply.
Any feedback is appreciated. Next show is Friday, and I'd love to have it smooth again by then.

Cheers,
Al



What arm are you using? if it has bearings or bushings for the arm post you need to clean them. If it's a Older Model 3 style arm clean the friction surfaces and clean the arm post with something like Frog Lube or ACF-50 that should take care of your issues
  • 0

#3 Alex Kolb

Alex Kolb

    Advanced Member

  • Members
  • PipPipPip
  • 82 posts
  • Midwest USA

Posted 01 November 2012 - 09:17 PM

Thanks very much for the quick response Eric! It does indeed have bearings, which I gave a nice cleaning, and now it's delightfully smooth.

Cheers,
Al
  • 0




rebotnix Technologies

BOXX

Wireless Video Systems

Boland Communications

Media Blackout - Custom Cables and AKS

Varizoom Follow Focus

PLC - Bartech

PLC Electronics Solutions

Omnishot Systems

Ritter Battery

Engineered Cinema Solutions

Betz Tools for Stabilizers

Paralinx LLC

GPI Pro Systems

The Moses Pole - Steadicam Monopod