Jump to content



Photo

TB6 buttons are stuck


  • Please log in to reply
2 replies to this topic

#1 thomas-english

thomas-english

    Advanced Member

  • Sustaining Members
  • 1165 posts
  • UK

Posted 19 October 2012 - 06:39 PM

None of the buttons on my TB6 work anymore and annoyingly there is a massive "CH 1" across the middle of my image. The ON-OFF button still works but nothing else.

When I turn it on there is contrast across the middle at maximum for a few seconds then it goes to "CH 1"

Are there any fixes I can do myself? It s been raining a lot here; I wonder if it got damp in there...
  • 0

#2 Twojay Dhillon

Twojay Dhillon

    Advanced Member

  • Sustaining Members
  • 184 posts
  • Santa Monica, CA

Posted 19 October 2012 - 07:46 PM

Thomas,

I had an identical problem with my TB-6 during a shoot in the rain. Had to shoot with the "CH 1" emblazoned right in the center of the screen! I received excellent advice from a veteran op, that being to take the casing off of the TB-6 (I think it's roughly 8 Phillips screws) and to let it dry out via natural evaporation (def drain out any obvious moisture).

Luckily, I was down for a few days and it worked perfectly when I put the casing back on and sent power and video to it.

Hope it works out for you in a similarly-painless-way. B)
  • 0

#3 thomas-english

thomas-english

    Advanced Member

  • Sustaining Members
  • 1165 posts
  • UK

Posted 20 October 2012 - 04:59 AM

Thanks mate... she's drying out now!
  • 0




Boland Communications

GPI Pro Systems

Media Blackout - Custom Cables and AKS

PLC Electronics Solutions

SkyDreams

Varizoom Follow Focus

Omnishot Systems

IDX

Paralinx LLC

Ritter Battery

PLC - Bartech

rebotnix Technologies

Betz Tools for Stabilizers

BOXX

Engineered Cinema Solutions

Wireless Video Systems

Teradek