Jump to content



Photo

New Pilot rig gimbal play ?


  • Please log in to reply
2 replies to this topic

#1 Mihai Nicolau

Mihai Nicolau

    New Member

  • Members
  • Pip
  • 5 posts

Posted 24 February 2012 - 01:44 PM

Hello,

I've just got my Pilot, ordered it from B&H. While playing with it today I noticed there is a slight play in the gimbal between the part that attaches itself from the handle and the part that stays fixed on the pole (don't know what their names are). It also makes a slight noise when it reaches horizontal position because of this play. It does this with or without a camera on the mount. Otherwise it is really smooth.
I'll put a picture up to illustrate better.
Should I worry ?

Thanks,
MihaiAttached File  pilot gimbal.jpg   57.39KB   106 downloads
  • 0

#2 Stavros Papastavrou

Stavros Papastavrou

    Member

  • Members
  • PipPip
  • 23 posts

Posted 03 December 2012 - 01:08 PM

Mine does that too.

Hasn't affected rig functionality or performance since 2009. (Can't say the same about my technique though...)
Go through the balance procedure and see if it has any performance issues... It should balance correctly.

Stavros
  • 0

#3 Alan Rencher

Alan Rencher

    Advanced Member

  • Sustaining Members
  • 1091 posts
  • Los Angeles

Posted 03 December 2012 - 02:22 PM

My first rig was the first generation Pilot, and I don't remember it ever doing that. You might try an RMA for another one. B&H is always really helpful about those kinds of replacements.
  • 0




Paralinx LLC

SkyDreams

Teradek

PLC Electronics Solutions

BOXX

IDX

PLC - Bartech

rebotnix Technologies

Boland Communications

GPI Pro Systems

Ritter Battery

Betz Tools for Stabilizers

Wireless Video Systems

Varizoom Follow Focus

Media Blackout - Custom Cables and AKS

Engineered Cinema Solutions

Omnishot Systems