Jump to content



Photo

Modulus Dealer?


  • Please log in to reply
3 replies to this topic

#1 JobScholtze

JobScholtze

    Advanced Member

  • Sustaining Members
  • 1361 posts
  • Netherlands

Posted 28 December 2004 - 04:35 AM

Hello Fellow Ops,

I have a strange problem with my Modulus 3000 transmitter. When i use the video out on a camera the picture looks too bright. ( like it's not closed )
When i use it in combination with my steadicam monitor using a T piece than the picture looks fine.

So i think i need a dealer or technician in Europe how is able to fix this. ( I hope i explained this right?)

Happy New Year to all of you

Greetings
  • 0

#2 Mikko Wilson

Mikko Wilson

    Advanced Member

  • Sustaining Members
  • 268 posts
  • Juneau, Alaska, USA

Posted 28 December 2004 - 10:37 AM

Not that I know much abotu the Modulus 3k, however, you have a termination problem by the sound of it!

The monitor is terminating the signal but the modulus is not. with a T peice the signal is terminated by the monitor. however without it isn't and that's why it looks too bright.

I don't know about how the modulus deals with temination but it sounds like it's not dooing it.
If it's selectable, than it should be set to on (when you arn't using the monitor). if it's not but should be on, then it could be borken. - Someone who knows the modulus, aswer this part please..

A quick fix is to use that T-peice - even without the monitor - and put a terminator on it. - A terminator beeing a 75ohm resistor between signal and ground.

The termination of video is 75ohms, so it may also go by just that name: "75ohm".

- Mikko
  • 0

#3 JobScholtze

JobScholtze

    Advanced Member

  • Sustaining Members
  • 1361 posts
  • Netherlands

Posted 28 December 2004 - 11:09 AM

Yes, that is what i do right now. Using an 75 ohm terminator ( arnold ?? :P )
but like to have it original again. But thanks for the reply. And no, no switch for it.



Job

( Edit: Just figured out that this is normal.)
  • 0

#4 Fred Davis

Fred Davis

    Advanced Member

  • Members
  • PipPipPip
  • 142 posts
  • Pasadena, CA

Posted 01 January 2005 - 02:30 PM

Not that I know much abotu the Modulus 3k, however, you have a termination problem by the sound of it!

The monitor is terminating the signal but the modulus is not.  with a T peice the signal is terminated by the monitor. however without it isn't and that's why it looks too bright.

I don't know about how the modulus deals with temination but it sounds like it's not dooing it.
If it's selectable, than it should be set to on (when you arn't using the monitor). if it's not but should be on, then it could be borken.(sic) - Someone who knows the modulus, aswer this part please..


Sounds to me like repair situation.
Contact the inventer Peter Spinelli at 207-284-5925 for consultation and repairs
  • 0




rebotnix Technologies

Media Blackout - Custom Cables and AKS

Varizoom Follow Focus

Engineered Cinema Solutions

GPI Pro Systems

PLC - Bartech

Ritter Battery

Omnishot Systems

Boland Communications

Paralinx LLC

Teradek

Wireless Video Systems

Betz Tools for Stabilizers

SkyDreams

IDX

BOXX

PLC Electronics Solutions