Jump to content



Photo

is my battery dead?


  • Please log in to reply
3 replies to this topic

#1 Adam Tyler

Adam Tyler

    Advanced Member

  • Members
  • PipPipPip
  • 34 posts
  • Los Angeles

Posted 01 September 2010 - 09:07 PM

one of my IDX v mounts has one blinking light for a meter and wont power anything. I tried charging it over night and its the same. any thoughts? its about 4 years old.
  • 0

#2 Blake Waldock

Blake Waldock

    Advanced Member

  • Sustaining Members
  • 43 posts
  • Perth, Australia

Posted 02 September 2010 - 01:51 AM

one of my IDX v mounts has one blinking light for a meter and wont power anything. I tried charging it over night and its the same. any thoughts? its about 4 years old.

Sounds like a dead cell. Has it had lots of cycles?
  • 0

#3 Adam Tyler

Adam Tyler

    Advanced Member

  • Members
  • PipPipPip
  • 34 posts
  • Los Angeles

Posted 02 September 2010 - 11:49 PM

no not really. it spent about a year without me touching it.
  • 0

#4 Adam Tyler

Adam Tyler

    Advanced Member

  • Members
  • PipPipPip
  • 34 posts
  • Los Angeles

Posted 19 September 2010 - 02:43 AM

I am extremely lucky. I put my "dead" battery on the charger for about 2 days and now it is working fine. I dont know what was going wrong but its back.
  • 0




PLC - Bartech

Varizoom Follow Focus

Paralinx LLC

Wireless Video Systems

GPI Pro Systems

Ritter Battery

Betz Tools for Stabilizers

PLC Electronics Solutions

Teradek

Omnishot Systems

BOXX

Media Blackout - Custom Cables and AKS

SkyDreams

rebotnix Technologies

IDX

Engineered Cinema Solutions

Boland Communications