Jump to content



Photo

bad GENESIS body


  • Please log in to reply
1 reply to this topic

#1 Jens Piotrowski SOC

Jens Piotrowski SOC

    Advanced Member

  • Sustaining Members
  • 1664 posts
  • Los Angeles, CA

Posted 23 July 2010 - 08:00 PM

had a bad PV genesis body yesterday that was drawing huge amounts of power, so that my dionics could not handle it, switched to A body, no problems. anybody had a similar experience...?
  • 0

#2 Ben Rowsell

Ben Rowsell

    Member

  • Sustaining Members
  • 26 posts

Posted 24 July 2010 - 01:29 AM

Someone from PV may be able to confirm this, but it sounds like you were probably experiencing a camera with a failing power module. I have seen this a couple of times in the last few years. The camera displays low voltage warnings but will still operate, record, etc - just xmas tree style with flashing warning lights. This is especially noticable when on (lower current) alternate power sources such as steadicam, hothead, etc, but may not be apparent when connected directly to the genesis block battery. Usually having PV swap out the power block module (inside the camera) fixes the problem - this should be able to be done in the field by a PV tech.

Ben R
AC
NZ
  • 0




rebotnix Technologies

Betz Tools for Stabilizers

Paralinx LLC

Varizoom Follow Focus

Engineered Cinema Solutions

PLC Electronics Solutions

Ritter Battery

Omnishot Systems

GPI Pro Systems

Boland Communications

PLC - Bartech

Media Blackout - Custom Cables and AKS

Wireless Video Systems

BOXX

The Moses Pole - Steadicam Monopod